Soporte MSXmakers

Página 7/9
1 | 2 | 3 | 4 | 5 | 6 | | 8 | 9

Por retrocanada76

Hero (538)

Imagen del retrocanada76

17-05-2022, 06:26

El problema no es la MFR, mira yo lo tengo la flash rom apagada sin tener una MFR conectada! El problema esta en que el SofaRun PIENSAS que la flashrom del Omega es una MFR y la intenta de utilizar.

Yo creo que son les comandos a de identification o una cosa parecida.

Si, creo ser posible la reprogramacion pero esto necesitaria de una RAM mas grande que 512KB.

Por retrocanada76

Hero (538)

Imagen del retrocanada76

17-05-2022, 06:38

Pero que creo que el problema es que yo utilizo a una MX29F040 y no la SST39SF040. Y hay una difefencia en los enderezos de comando por ejemplo la MX29 utiliza 0555H pero la SST39S 5555H

Por andongniao_vnb

Supporter (14)

Imagen del andongniao_vnb

17-05-2022, 23:41

Muchísimas gracias msxmakers!

Por msxmakers

Champion (453)

Imagen del msxmakers

21-05-2022, 15:24

retrocanada76 wrote:

El problema no es la MFR, mira yo lo tengo la flash rom apagada sin tener una MFR conectada! El problema esta en que el SofaRun PIENSAS que la flashrom del Omega es una MFR y la intenta de utilizar.

Yo creo que son les comandos a de identification o una cosa parecida.

Si, creo ser posible la reprogramacion pero esto necesitaria de una RAM mas grande que 512KB.

Hola,
¿entonces dices que es una forma de configurar el sofarun?
¿que versión estas / estais utilizando?
Quiero hacer pruebas, pero el problema para grabar la ROM no es tener RAM suficiente, el Omega en realidad solo puede ver 256K de firmware a la vez, con lo que, no se si sofarun puede estropear el contenido pero dificilmente podrá grabarlo, no se puede grabar medio chip flash solo.
saludos.

Por itozzz

Rookie (29)

Imagen del itozzz

22-05-2022, 22:35

Buenas a todos, por fin he terminado mi omega, todo parece ir bien a la primera, solo tengo un problema que no doy con la solucion:
No me funcionan las teclas SHIFT, CTRL, Bloq Mayusculas (CSLK) y la tecla KANA/CODE.
Revise los cherry switch, las conexiones y todo parece correcto, incluso desolde el puente de JP2 y le puse un jamper por si era algo del tipo de teclado pero nada, el resto de las teclas funciona correctamente.
Me di cuenta por que no me encendian los led de Bloq. Mayusculas y el code/kana, pensaba que era led invertido pero no.
Alguna ayuda?.

Gracias.

Por retrocanada76

Hero (538)

Imagen del retrocanada76

23-05-2022, 09:52

El problema como he dicho es porque yo utilizo a una MX29F040 (la misma de MFR SCC) y no la ST39SF040 de las especificaciones de omega. La flash MX29 funciona muy bien pero corre el riesgo del Sofa Run v8.0 la confundir con una MFR y la apagar. Si quires hacer un testeo tienes que poner una MX29 en su omega.

Los enderezos de programacion de la SST39 y la MX29 son diferentes por esto este problema solamente se pasa com una MX29.

Si podriamos hacer un programa para grabar el banco de bajo solamente. No hay como grabar el banco superior porque el enderezo de comandos eh el 5555h para la SST39 y 0555h para la MX29. Cuando chaveamos el banco de ROM no podremos mas acceder fisicamene los 5555h y 0555h. (se pasan por 15555h y 10555h).

Y esto programa tendria que ser auto suficiente y correr sin acceder la ROM. Una vez que has cargado todos los datos a la Memory Mapper no necesitamos mas de la ROM.

Por retrocanada76

Hero (538)

Imagen del retrocanada76

23-05-2022, 10:18

Olvidatelo que dices sobre el banco superior.
". The system should generate the following address patterns: 555H or 2AAH to Address A10~A0 .
Address bit A11~A18=X=Don't care for all address commands except for Program Address (PA) and Sector
Address (SA). Write Sequence may be initiated with A11~A18 in either state"

Esto quieres decir que podremos si programar la flash msimo con el jumper cerrado. El programita podria preguntar al usuario para que abra u cerre el jumper con esto podriamos grabar en todo el 512Kb. Y tambien hay la memoria VRAM para guardar los datos en una omega stock 51kb.

Por msxmakers

Champion (453)

Imagen del msxmakers

23-05-2022, 14:29

itozzz wrote:

Buenas a todos, por fin he terminado mi omega, todo parece ir bien a la primera, solo tengo un problema que no doy con la solucion:
No me funcionan las teclas SHIFT, CTRL, Bloq Mayusculas (CSLK) y la tecla KANA/CODE.
Revise los cherry switch, las conexiones y todo parece correcto, incluso desolde el puente de JP2 y le puse un jamper por si era algo del tipo de teclado pero nada, el resto de las teclas funciona correctamente.
Me di cuenta por que no me encendian los led de Bloq. Mayusculas y el code/kana, pensaba que era led invertido pero no.
Alguna ayuda?.

Gracias.

Hola
las tecls que mencionas estan en la misma fila (ROW6 o ROW6 unbuffered) tienes que mirar el pin 8 de U2, el pin 9 de U2 o el pin 7 de u1, con un osciloscopio.
apuesto a que uno de esos puntos tiene una soldadura fria o una mala conexión en el zócalo.
saludos

Por itozzz

Rookie (29)

Imagen del itozzz

23-05-2022, 19:21

Vaya ni que lo hubieras visto... precisamente el pin 8 no hacia conexion, fue repasarlo y funcionar todo bien.
Eres un crack!!. Muchas gracias Face

Por msxmakers

Champion (453)

Imagen del msxmakers

23-05-2022, 19:39

itozzz wrote:

Vaya ni que lo hubieras visto... precisamente el pin 8 no hacia conexion, fue repasarlo y funcionar todo bien.
Eres un crack!!. Muchas gracias Face

es mirar el esquema.
Los circuitos de teclado son muy sencillos, y si fallan varias teclas, suele ser que la fila es comun (no la fila fisica sino la conexión que las une y que en el esquema se llama row.
muchas de nada.
Hannibal Hannibal Hannibal

Página 7/9
1 | 2 | 3 | 4 | 5 | 6 | | 8 | 9