Seed of Dragon on openMSX

By Argon

Paragon (1126)

Argon's picture

05-02-2017, 18:34


I've been a very bad boy, I downloaded a disk game, more specificly Seed of Dragon for turboR.
(Actually I own the original, so I guess that's not really all that bad of me ;-) )

So I chose turboR GT as machine in openMSX and inserted disk 1 of the game.

At first I get a screen where I need to select "Video" or "RGB", but no matter what I choose, after that the openMSX OSD (on screen display) shows flashing lights for "turbo" and "FDD", but nothing happens...

Any suggestions to get this one running?

Thank you guys!

Login or register to post comments

By Manuel

Ascended (19465)

Manuel's picture

11-12-2020, 08:57

I actually see the same thing happening now with a dump that is quite original... Anyone has an idea about this?
Looks like a copy protection perhaps?

Are there multiple versions of this game?

By Sylvester

Hero (589)

Sylvester's picture

11-12-2020, 09:01

Not that I know, but my copy is working on both ST and GT machines. So maybe a bad dump? or a copy protection that isn't removed?

By Manuel

Ascended (19465)

Manuel's picture

11-12-2020, 21:04

The working vs non-working had only 2 bytes different. At offset 0x1C00 there is 00 in the non-working and 03 01 in the working version. That does not look like copy protection to me, what do you think?

By jepmsx

Master (253)

jepmsx's picture

29-08-2022, 17:59


I think that the problem is the emulation in openMSX.

I've tried the old images that I had in my hard drive and they run without problem. I've copied those dsk files in my Linux PC and run them with openMSX and they have that problem of the flashing lights.

When I've played my old images in MSX, when the first disk is on, I can choose the area that I've visited to start (although you have 0 energy balls). Maybe the differences of these bytes are the area to start. When I start the first disk with the 0s as Manuel says, it starts but without choosing any area to begin.

By jepmsx

Master (253)

jepmsx's picture

03-09-2022, 13:46

oO Oops! My mistake. I've tried my old files again with the A1GT model and it has worked. I've checked the A1ST model and it has also worked.
Maybe I confused files.
I'm so sorry to have doubt of openMSX. It's the best simulator.

By Daemos

Prophet (2063)

Daemos's picture

03-09-2022, 14:00

Even with older versions of openmsx I rarely encounter differences with the real thing. In fact i recently played my little project on openmsx and even the corner glitch has dissapeared since version 17. The precision of openmsx is very very good.