Problem saving game with SD-SNATCHER Project Melancholia.

By javilevel

Expert (107)

javilevel's picture

21-10-2014, 23:43


First sorry for my english.

I'm javi from Spain, and I buyed a copy of this excellent translation, but I have a problem.

I have a MSX turbo R with 512k, with a PADIAL SD CARD, And a Megaflash Rom SCC.

I write de three disks in the memory of the SD card, and when I boot de game's runs ok. but when I'm trying to save the game I have a lot of problems.

I press de F2 key to save, choose the user's disks but the Fdd dont charge. The game dont do the signal to the FDD. My FDD is OK.

I tried to charge the three SD-SNATCHER disks and the four disk I put the users disk. And when I go to save state, y chose the user disk and now the game makes me chosse a number 0 to 9. But when I chose anyone it doesnt work.

trying and trying this now, when I start my MSX and boot the game, my MSX goes directly to the BASIC.

What's happen?

I tried to erase the boot in the SD, and tried another SDMMCEP with the three disks, but goes directly to the BASIC.

Login or register to post comments

By Imanok

Paragon (1200)

Imanok's picture

21-10-2014, 23:58

You must be disabling any other disk interface with the parameters sent to SDMMCEP. That's why the FDD doesn't seem to work.

By Moniz

Champion (401)

Moniz's picture

22-10-2014, 08:35

Do you use a blank dsk image as userdisk?
IIRC a user disk came with the patch that has to be used.

By javilevel

Expert (107)

javilevel's picture

24-10-2014, 23:00

Thanks the problem is solved.

The problem is in the modificator of the command SDMMCEP /b /f. The /f don't make me save in the SD.