Location of settings.xml on Raspberry (multiple?)

By Zwarteziel

Rookie (24)

Zwarteziel's picture

06-08-2022, 15:53

Hi,

On the Raspberry (Raspbian lite 32), I recently changed some settings for OpenMSX by editing the file [settings.xml] located in /usr/share/openmsx. These worked, and after the initial boot I altered some of them to experiment with performance.
Now, I notice that the altered settings are being loaded properly when OpenMSX starts, but that they have not been saved to the file I first edited. Also, new alterations to this file are not being used.

Is there perhaps another "master"-settings.xml file, besides the one that resides in /usr/share/openmsx? If so, where can I find it?
Thanks! Smile

Login or register to post comments

By Manuel

Ascended (18959)

Manuel's picture

06-08-2022, 16:15

There is a system settings.xml in the location you mentioned and a user settings.xml in the user home directory. Settings are always saved in the user directory.

By Zwarteziel

Rookie (24)

Zwarteziel's picture

06-08-2022, 23:30

Thank you, I was able to find it!

By smx

Resident (62)

smx's picture

07-08-2022, 18:42

Can you indicate what performance you can achieve with Raspbian Lite?

Does it support 60 FPS for example with "Space Manbow"?

Select "Menu \ Advanced \ Toys and Utilities \ Info Panel" to obtain performance panel

Thanks

By Zwarteziel

Rookie (24)

Zwarteziel's picture

07-08-2022, 22:15

Quote:

Can you indicate what performance you can achieve with Raspbian Lite?

Hi smx,

sure, no problem: Space Manbow runs at 60.0 fps most of the time, but with occasional hickups. When framedrops occur, they range between 54~57 fps, although I've seen rare drops to ~41 fps. All the framedrops occur briefly and are not sustained for long (more like small spikes). All-in-all I'd say the game is pretty playable, although I cannot compare the experience with real hardware at the moment.

The settings I'm using currently are:
Pi:

  • resolution: 640x480
    (set with framebuffer_width/framebuffer_height and hdmi group 2, mode 4 in config.txt)

OpenMSX:

  • Machine: Panasonic_FS-A1GT
  • Fullscreen: true
  • Scaler: simple
  • Scale factor: 2
  • Blur: 0
  • Noise: 0
  • Maxframeskip: 2
  • Resampler: blip

The Pi400 can be overclocked slightly, so I'm going to give that a try, just to see if the framedrops can be reduced.

By Zwarteziel

Rookie (24)

Zwarteziel's picture

07-08-2022, 22:11

A short follow up on my previous post:
I tried the overclock by editing the PI's config.txt (arm_freq=2000, over_voltage=6) and this worked perfectly: Space Manbow now runs quite steady at 60.0 fps. I've seen it go down to 58.8 fps for slight moments, but nothing really noticable when not looking at the fps counter.