TriloTracker beta thread.

Pagina 39/52
32 | 33 | 34 | 35 | 36 | 37 | 38 | | 40 | 41 | 42 | 43 | 44

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 09:15

Wink Thanks. I'm still on it. Not able to find the issue yet.

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 10:47

giangiacomo.zaffini wrote:

I tried again TT v0.8.0 from demo zip and TT compiled v0.9.1 on a MSX2+ Panasonic FS-A1FX with memory expanded to 512 kB and on a MSX turbo-r Panasonic FS-A1ST with memory expanded to 512 kB calling TT from a megaflashron scc+ 512kB SD in slot 1.
All the four combinations TT + machine work very well when playing TMU files but all the four combinations halt entering configuration page with SHIFT-F5.
Just as a remainder.

Is there any change of testing the program without the MegaFlash SCC+ SD?
I have just retested on my own turbo-R FS-A1ST (256kb) from a floppy and it works without any issues.

Van ssfony

Expert (83)

afbeelding van ssfony

14-03-2016, 11:39

I did another test:

Sony HB-F1XDJ
slot1 = DOS2.20
slot2 = playsoniq (for RAM and SCC)

TT runs from floppy, boots, doesn't detect playsoniq SCC (this is a known issue).
Pressing F10 (shift-F5) doesn't crash the system!

So it seems that the problem might haves something to do with the MegaFlahRam SCC+ SD?
I also tested with a MFRSCCSD instead of the DOS2.20 cart, but with the 512mb disabled. Still crashes on F10.

BTW, playsoniq has PSG at 48h by default, but it can be changed to 10h too, so no big deal. Too bad of the SCC still not being detected though...

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 12:14

ssfony wrote:

I did another test:

Thanks!!

ssfony wrote:

So it seems that the problem might haves something to do with the MegaFlahRam SCC+ SD?

I can't say. I really don't understand why it would cause this behavior. I'll try to look into it.
Probably I have to start saving to buy one myself to be able to effectively find the issue.

Van Grauw

Ascended (10617)

afbeelding van Grauw

14-03-2016, 12:57

@ssfony The PlaySoniq has an Texas Instruments SN76489 (Master System), not a General Instrument AY-3-8910 PSG, so it’s not compatible with the MSX PSG.

@Huey MegaFlashROM SCC+ SD is emulated by openMSX, maybe it’s reproducible there?

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 13:14

@@ssfony: What happens if you press F4 (Track Manager)?
These menu's are similar looking at how they start. They are first loaded from VRAM to RAM.

Van giangiacomo.zaffini

Champion (267)

afbeelding van giangiacomo.zaffini

14-03-2016, 13:47

@ Huey : I will test again running from floppy disc. I cannot do it before the weekend because I don't have MSX machines with me.

Van ssfony

Expert (83)

afbeelding van ssfony

14-03-2016, 15:01

@Huey: F4 works fine...
@Grauw: ok, too bad, I was allready dreaming of 9 channel PSG sound combining all my cartridges...

I did some more testing:
- I adapted a Nextor ROM file for my old SCC cardtridge with Flashrom (with a little help from Konamiman Smile )
- replaced the DOS2 cartridge in the HB-F1XDJ by this nextor/scc cartride
- boot from floppy and voilla, a working trilotracker + scc sound

So, nextor isn't the problem either.

The last test I did is even more interesting:
- HB-F1XDJ
- slot1 = MFRSCCSD512

Boot from SD, then switch to the internal floppy (C: in my case)
Run tt from root folder
F10 doesn't crash!!!!
After loading music and playing, press F10 again -> crash Sad

Using the same setup:
run tt from SD (b:\transfer\tt9\)
F10 crashes...

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 17:01

That's strange. I'm puzzled.

The only thing I could think of is a DOS call I make to get the path+filename of tt.com.

Van Huey

Prophet (2687)

afbeelding van Huey

14-03-2016, 16:44

Grauw wrote:

@Huey MegaFlashROM SCC+ SD is emulated by openMSX, maybe it’s reproducible there?

No idea how it works. I see it on catapult but no result when starting it. I guess it's not really OTB functionality.

Pagina 39/52
32 | 33 | 34 | 35 | 36 | 37 | 38 | | 40 | 41 | 42 | 43 | 44