Toshiba HX-10 Repair

Door ArkadiuszMakarenko

Supporter (14)

afbeelding van ArkadiuszMakarenko

03-10-2021, 13:56

Unfortunately after taking my MSX from storage it decided to unalive itself.
Now I have big fat short on +5V line to Ground.

I have checked big transistors on power supply circuit and zener diodes. Those seems to be fine.

All IC are stone cold, so I can't see obvious place of short.

Are there any known reasons for similar faults?

Aangemeld of registreer om reacties te plaatsen

Van gdx

Enlighted (5813)

afbeelding van gdx

03-10-2021, 14:38

Check the capacitors.

Van SkalTura

Champion (368)

afbeelding van SkalTura

03-10-2021, 15:57

gdx wrote:

Check the capacitors.

Yes, most likely a capacitor.
Check if you can see a bulge in the caps, or maybe even a leak.
If not, check what capacitors are in the 5V circuit (maybe you can find a schematic of the PCB), and de-solder them one at a time to measure if the short is gone.

Or just replace them all just in case...

Van ArkadiuszMakarenko

Supporter (14)

afbeelding van ArkadiuszMakarenko

03-10-2021, 16:41

Unfortunately there is no schematics for this PCB.
Fortunately there is not that many of them.

Van Wierzbowsky

Guardian (3526)

afbeelding van Wierzbowsky

03-10-2021, 18:06

Check the slot, as well as the bus expansion connector in the back. Also, check both joystick ports to see if there are no shorts there.

Then my bet would be on one of the transistors or voltage regulators. And then - caps. Even a ceramic cap can create a short between power and ground rails.

Van ArkadiuszMakarenko

Supporter (14)

afbeelding van ArkadiuszMakarenko

03-10-2021, 18:45

I have bad feeling.
I took 4164 ram and short from 3ohm went to 300ohms.
But power supply still can't produce all voltages.
I have feeling that PSU failed and took a lot of chips with it.

Van ArkadiuszMakarenko

Supporter (14)

afbeelding van ArkadiuszMakarenko

05-10-2021, 20:05

I have acquired motherboard replacement on eBay. So I will be able to continue my hardware tinkering Smile

Van gdx

Enlighted (5813)

afbeelding van gdx

06-10-2021, 13:22

I don't think the second motherboard is useful. What causes the problem in general are the capacitors, RAMs / VRAMs, video circuit chips or the micro-switch in the cartridge slot. It can also be a bad contact of the chips having a support or elsewhere. Check cables and welds.

About capacitors, verify if current does not flow through continuously with an ohmmeter (black to - and red to +), and if the pins do not touch a track or a pin nearby.

Van ArkadiuszMakarenko

Supporter (14)

afbeelding van ArkadiuszMakarenko

06-10-2021, 22:09

I will work a little bit more on it, when time allows, but I need to have reference board first, I need to do something on MSX!

I have removed some RAMS already, and after each one removal resistance between +5V and GND was rising a little.
I will try the same with VRAM, maybe I this will solve the issue?

I removed almost all decoupling caps I have only few left on 5V rail.

Arek