HELP PLZ SDMAPPER v2 512k belavenuto

Pagina 3/4
1 | 2 | | 4

Van sdsnatcher73

Prophet (3551)

afbeelding van sdsnatcher73

25-06-2022, 06:57

I have had v1 mapper it should alway show a large information message during boot. You can check it in this video at around 6:30 in. If there is no SD the message is still shown (both slots will show empty).

The message you see is something different, in my opinion it is Nextor kernel saying the driver was not loaded. A driver in Nextor is the piece of software that communicates to the storage interface and it is different between hardware. So a MegaFlashROM SCC+ SD needs a different driver than a Carnivore2. Likewise your device needs a specific driver. The driver should be in the SDMAPPER.ROM.

Now there are 2 options: either the driver is not there, or it is not functioning properly. Why it is not functioning properly could be a software bug or a hardware issue.

The message shown in the video is printed by the driver in the V1 they use.

Van sdsnatcher73

Prophet (3551)

afbeelding van sdsnatcher73

25-06-2022, 07:11

The driver code for the v2 is located here after some checks the first thing it will do is print a title string:

If you don’t see that title on your screen the driver is not loaded.

The code talks about a MAIN BIOS and DEV BIOS switch. From your photo I can only assume it is the one in the center of the board. Have you tried changing its position? Possibly you have the wrong BIOS activated (not the one you flashed).

All of this is before your SD card is accessed so for now there is no reason to believe your SD card is not working.

Van sdsnatcher73

Prophet (3551)

afbeelding van sdsnatcher73

25-06-2022, 07:21

In this video you see the v2 in use. At 0:07 you see the title being printed and also that the Main driver was selected. I made a screenshot because it passes quickly.

Van Pentarou

Champion (462)

afbeelding van Pentarou

25-06-2022, 13:14

@ OP: Please give us more info...
You flashed the BIOS, but why did you do it? Was the card working before you flashed it?
Or maybe you built it from scratch (Different can of worms in this case)?

About the SD card formatting: The cartridge should give you the DISK BASIC prompt even without a SD card inserted, so your problem lies elsewhere.

Van darlei3

Rookie (21)

afbeelding van darlei3

26-06-2022, 19:25

Pentarou wrote:

@ OP: Please give us more info...
You flashed the BIOS, but why did you do it? Was the card working before you flashed it?
Or maybe you built it from scratch (Different can of worms in this case)?

About the SD card formatting: The cartridge should give you the DISK BASIC prompt even without a SD card inserted, so your problem lies elsewhere.

I fried the altera and the eprom in a short circuit. then replace them with new ones. and installed the driver that is on github using a TL866 and programmed the new alter with the code
vcc out and gnd regulator closed

Van darlei3

Rookie (21)

afbeelding van darlei3

26-06-2022, 19:27

sdsnatcher73 wrote:

In this video you see the v2 in use. At 0:07 you see the title being printed and also that the Main driver was selected. I made a screenshot because it passes quickly.

Will the github driver not be compiled? and being halfway there, I saw people here on the forum with similar posts with the same error

Van darlei3

Rookie (21)

afbeelding van darlei3

26-06-2022, 19:37

nobody there has the sdmaper v2 version to give this am29f driver? make dump via software

Van Pentarou

Champion (462)

afbeelding van Pentarou

26-06-2022, 19:45

darlei3 wrote:

I fried the altera and the eprom in a short circuit. then replace them with new ones.

There is NO Altera chip in this card. The MG version uses Altera, but Belavenuto's uses Xilink.
And you haven't answered... Was the cart working before you fried the ICs?

Anyway check your soldering, especially the Flash high address pins.
Another thing to try is to fill all the ROM space with 4xcopies of the SDMAPPER.BIN

darlei3 wrote:

I saw people here on the forum with similar posts with the same error

Most of the times people can't boot from the SDCARD, your problem is different.

Van darlei3

Rookie (21)

afbeelding van darlei3

26-06-2022, 21:43

I said wrong and an xc95144xl I bought to replace
it worked for a short time the regulator closed the poles
I don't have a backup of the rom there that must be my problem

Pagina 3/4
1 | 2 | | 4