Another strange VDP behavior?

Door PingPong

Prophet (3919)

afbeelding van PingPong

30-07-2022, 11:57

Hi, all.
Time ago, someone mentioned a issue about different vdp timings when performing a vram read. Basically:
A) on TMS one can set up the vram ptr and then do a in on data port, reading the value without any delay
B) it seems that V99x8 require a small (2us) delay (two nops or so) to return the correct data after setting up the vram ptr.

Now, it is known that after address setup there is a small interval to wait called on TMS docs the "VDP Delay". What's happening is that the VDP issue a read after setting vram ptr into a internal buffer. A input for a dataport return the value and trigger a successive read into the buffer. This is called read ahead.

What does appear to me extremely weird is that, despite the fact that the TMS doc explicitly mention the VDP Delay the read on TMS seems to not need the 2us delay, while the v99x8 require it. This is very strange due to the fact that the v99x8 is more fast in I/O memory operation than the tms vdp.

Has anyone proved this reliably? what could be the reason?
thx in advance

Aangemeld of registreer om reacties te plaatsen

Van gdx

Enlighted (5711)

afbeelding van gdx

30-07-2022, 13:20

It is on TMS that the delay is needed.

Van PingPong

Prophet (3919)

afbeelding van PingPong

30-07-2022, 18:36

OK, I know. However my point is that some one on mrc (did not remember) told that ON TMS THE DELAY IS NOT Needed while on v99x8 it is required. This sound strange to me, it would be more understandable the opposite given the fact that v99x8 memory interface is faster than tms one.