Carnivore2 Setup Help

By greekplaya990

Supporter (2)

Аватар пользователя greekplaya990

10-06-2022, 04:49

Hey guys I'm hoping to get some help understanding the setup process for the Carnivore2

So the first bit seems easy with partitioning the drive with CALL FDISK. I now have the card formatted with a partition and am able to drag the Nextor System Files from the https://sysadminmosaic.ru/en/msx/carnivore2/carnivore2#c2man... site they had me download to the root directory of the partition.

From there though I'm unable to figure the next steps since it doesn't seem im able to boot into MSX-DOS2 or whatever I'm supposed to do next. Any help? I'm looking to end up with sofarun and having rom or whatever game backups required on the CF card.

Thanks for all the help! :)

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By Manuel

Ascended (18842)

Аватар пользователя Manuel

10-06-2022, 07:52

Are you booting into basic with the message "Nextor basic version xxx"?
What happens if you type the FILES command there?

By greekplaya990

Supporter (2)

Аватар пользователя greekplaya990

11-06-2022, 03:29


I get the DISK I/O Error when I type the FILES command in BASIC with a brand new Sandisk 64GB drive (SDCFXS-064G-A46). I am Using a Sony HB-101 and getting to BASIC by hitting escape in the Carnivor2 v.2.50 menu.

And here's what I've got after I partitioned the drive with CALL FDISK and created the maximum sized partition and copied the files from the tools.zip folder from the instructions to the root directory.

By Jipe

Paragon (1552)

Аватар пользователя Jipe

11-06-2022, 06:15

By gdx

Enlighted (5570)

Аватар пользователя gdx

11-06-2022, 07:55

It is better to avoid taking a card larger than 4GB.

By sdsnatcher73

Prophet (3368)

Аватар пользователя sdsnatcher73

11-06-2022, 08:37

Does your HB-101 still have its firmware? I suspect this is pretty much the cause. You end up in BASIC with Disk Basic 1.0. So Nextor is not active.

By sdsnatcher73

Prophet (3368)

Аватар пользователя sdsnatcher73

11-06-2022, 08:49

It’s best to remove the firmware altogether or replace it with a version that does not automatically start on boot (this has to be created). There are 2 ROMs on the mainboard one is 256kb and one is 128kb (kilobit that is, so 32kB and 16kB respectively). If you desolder the 128kb ROM the firmware is gone. If you have no experience with that please find someone to do it for you.

In the mean time there is an awful keycombo to disable the firmware. According to the wiki you have to press CTRL-SHIFT-CODE-GRAPH when booting. And you probably have to do it to get to C2 bootmenu and then again directly after. For now setting the default config to autoboot in C2 seems wise, you can then probably boot directly to nextor while booting with the aforementioned keys pressed until the CF detection is displayed on screen.

By Manuel

Ascended (18842)

Аватар пользователя Manuel

11-06-2022, 10:05

Perhaps you can make a video of the entire boot process. Main issue is that Nextor doesn't seem to be active indeed.